読者です 読者をやめる 読者になる 読者になる

Mac OSのbuilt-in vim(/usr/bin/vim) 使うのを辞めた

最近ホットな Vim Plugin 3つを読んでいてvim-over入れたくなったことがきっかけ

NeoBundleでインストールして使おうとしたらエラー

NeoBundleでvim-overのインストール。早速使おうと:OverCommandLineしたら以下のメッセージが出て手詰まり

Vim 7.3 or above.
Need strchars() and +conceal.

ググったらgithubのissueがヒット

Vim 7.3 or above. とエラーが表示される · Issue #10 · osyo-manga/vim-over

vim --versionで確認したところ-concealとなっていたためbuilt-inのvim(/usr/bin/vim)使わないことを決意。

MacVimに移行

もともとMacVim入れていたので/Applications/MacVim.app/Contents/MacOS/Vim --versionしてみたところ+concealだったのでalias設定

alias vim="/Applications/MacVim.app/Contents/MacOS/Vim”

:OverCommandLineしたら使えた!

/Applications/MacVim.app以下にvimが入っていたことを知らなかった。 vim-overのインストールを機に知ることが出来たので良かった。